Skip to Main Content

Breadcrumb

Question and Answer

Chris Saxon

Thanks for the question, Swami.

Asked: May 16, 2000 - 3:21 am UTC

Last updated: August 24, 2021 - 4:01 pm UTC

Version: 8.1.5

Viewed 1000+ times

You Asked

I have installed Oracle Enterprise Manager (OEM) Version 2.1
which was on free download from OTN ( technet.oracle.com ).

Problem is when I launch the console it asks me to logon into
a Management Server, So What is a Management Server and how do
I create a Management Server ?. Also , In Previous Versions of
OEM , there was a utility to create Repository but in the new
version I could not find any such thing.

Please Help

Thanks

and Tom said...

What is the Oracle Management Server (OMS)?

The Oracle Management Server is a new component to the Oracle Enterprise Manager architecture. OEM V1 was based on a two-tier architecture of Client/Server. Communications with the Intelligent Agent were performed by the OEM Communication Daemon, which ran on the OEM Client system. However, OEM V2 is based on a three-tier architecture of Client, Management Server, and Application. Processing and communications that were the responsibility of the Communication Daemon are now being performed on the middle-tier by the Management Server. It is the responsibility of the OMS to communicate with the Intelligent Agent and store all related information in the OEM Repository. The OEM Client connects to the OMS to retrieve the information that is stored in the OEM repository.


How to set it up?

You would use the Oracle Enterprise Manager Configuration Assistant (OCA) to configure this middle tier.

You use the OCA to create the repository as well.




Rating

  (52 ratings)

Is this answer out of date? If it is, please let us know via a Comment

Comments

Norman Waldie nwaldie@technologist.com, June 04, 2001 - 12:51 pm UTC


Helena Markova, July 06, 2001 - 3:51 am UTC


OEM

atul, November 27, 2002 - 9:05 pm UTC

Sir,

I have installed oracle 8.1.7 on red hat linux 7.1
(typical installation) ..
I'm using this as a test server..so on single machine i'm the client as well server..

How should i launch OEM in my environment??
could you provide me stpes for that???


Thanks.
atul

Tom Kyte
November 28, 2002 - 7:49 am UTC

just run oemapp console and use the standalone config if you want.

Rahul, February 06, 2003 - 1:07 am UTC

Hi Tom,

Thanks for the reply of OEM, as i fixed it, was my mistake had changed the entry of tnsnames.ora.

1. I am trying to set paging server which dials through modem and I want to send text messgs to my cell phone. Which protocol should i use, as I tried all three (TAP,FLEXTD,GSM) from OEM but it dials my cell phone(no text messg).

2. If i want to send text messg to my cell phone thru (SMTP) how should i go about.

Thanks.


Tom Kyte
February 06, 2003 - 7:58 am UTC

no idea -- i don't have a pager, don't have text messaging, never used this facility of oem.

OEM Notifications

Terry, February 06, 2003 - 8:43 am UTC

With Regards to Paging and email from OEM. This is a very useful feature and not too difficult to setup.

The simple highlights of what needs to be done.

You need to discover the node against which you will create some events by right clicking the node folder in the OEM Console once you've logged onto the management server. Perhaps in your case after you've created the server with the Enterprise Management Creation Assistant (EMCA actually).

You need to configure the paging/email from the Configuration/Configure email/paging item on the OEM Console Title Bar(add an smtp gateway and user)

You need to configure preferences from Configuration/Preferences item on the OEM Console Title Bar. Select Notifications (add a receiver to the configuration).

You need to configure scheduling for email periods. Go to Configure preferences from Configuration/Preferences item on the OEM Console Title Bar. Select Schedule, click on email and add the notification periods to the configuration).

There is a test button under Configuration/preferences/Notification for both email and paging.

It all looks a bit counter-intuitive (those Java programmers thinking they know UI design, drives me nuts!) but when it is working it is awesome and saves you big$$$ over similar products that cost potentially hundreds of thousands of dollars (BMC Patrol, HP OpenView, iWatch) all which are fine products, just way too much money and while they have some extra bells whistles almost no one uses them.

I usually have this up and running in 30 minutes or less and you can't do that with BMC Patrol or HP OpenView or Quest iWatch.

Have fun

oem and rman backup error

Reader, July 03, 2003 - 12:46 pm UTC

Tom, I receive the following error when i submit a backup job in oem. Could you please help me where I should set up credentials to "Logon as a batch job" privilege. THANKS.

I am using oem version 9.2.0 on Windows 2000.

VNI-2015 : The Node preferred credentials for the target node are either invalid or do not have sufficient privileges to complete the operation.
On Windows platforms, the Node credentials specified for the Windows target should have the "Logon as a batch job" privilege.

Following info from 'help' button on oem.

For NT users, you must set the preferred credentials for the node (where the NT Agent resides) to be the same as the user that is set up to "Logon as a batch job."

Where to find OCA ?

Alvin, December 05, 2003 - 4:39 am UTC

1. Where can i find the Oracle Enterprise Manager Configuration Assistant (OCA) ?? i've installed the oracle client (for DBA ) and i can't find it.

2. Where do i install the OMS on the target db or on the client (my workstation )?



trying to start the agent ....

Reader, January 08, 2004 - 8:48 pm UTC

When I try to start OracleOraHome92Agent service on my windows 2000, it throws a following error.
<quote>Could not start the OracleOraHome92Agent service on Local Computer. The service did not return an error. This could be an internal windows error or an inter service error<quote>

Could you please guide me what should I do? Thanks.

Tom Kyte
January 09, 2004 - 7:58 am UTC

contact support please for installation/configuration help.

A reader, July 15, 2004 - 11:33 am UTC

How can I configure OEM to access my database remotely

Tom Kyte
July 15, 2004 - 1:25 pm UTC

it just "happens", you connect with user/pass and a connect string.

Help!!!!!!!!!!

A reader, August 14, 2004 - 1:57 pm UTC

Hi Tom,
I am working with Oracle 9iR2 OEM. Today I was using the Index Tuning Wizard on a specific user and got the following error:
XP-21166: The requested column item no longer exists. It may have been removed by another Tuning Pack tool.

The action stated is:
Cause: The Oracle Expert shares its repository with
other Tuning Pack tools. It is possible that a
second tool has removed the item while the
current tool was idle.

Action: Exit the current Tuning Pack tool and restart.

I restart it and still the error occurs. But the strange thing is that it works successfully for other users.

Only in case of this user it generates the above mentioned error.
Any guidance......
Thanks.

Tom Kyte
August 14, 2004 - 2:12 pm UTC

i'll have to refer you to support, never used that particular tool myself.

Backup, Reorg Jobs are getting failed

JH Suryakanth, August 15, 2004 - 3:39 am UTC

Hi,

When I submit a job, it is being submitted successfully, but the status of the job is saying "failed". When I go for SHOW OUTPUT optiong from Oracle Enterprise Manager Console it is showing the following error.

VNI-2015 : The Node preferred credentials for the target node are either invalid or do not have sufficient privileges to complete the operation. On Windows platforms, the Node credentials specified for the Windows target should have the "Logon as a batch job" privilege.

plz. help me to solv the above problem.

thanks

with regards,
Suryakanth

Tom Kyte
August 15, 2004 - 9:28 am UTC

search for

VNI-2015

on this site or even better -- metalink (the support site)

Intelligent Agent

Sean, August 16, 2004 - 11:24 am UTC

I got the same error in Unix system, which is solved by changing the owner of the file ORACLE_HOME/bin/dbsnmp
to root after reading this book:
</code> http://download-west.oracle.com/docs/cd/B10501_01/em.920/a96676/chap2.htm <code>

You can take look at Window portion



Very useful

jharvu, August 30, 2004 - 2:28 pm UTC

I have installed OEM 9.2.0.1.0 on my desktop and since there was no middle tier identified , I went ahead with the standalone. Now I have a middle tier and I want to switch to OMS , but I do not know how to proceed. I dont see the EMCA any more. Can you direct me to any help source , please ?

Thanks in advance.

Tom Kyte
August 30, 2004 - 2:48 pm UTC

metalink.oracle.com is always a good source for configuration/installation issues. sorry -- i've never configured 9i EM myself.

EMCA

reader, August 31, 2004 - 2:03 pm UTC

go to command prompt:

Start>cmd> go to the oracle home directory drive

type emca

this works on Windows NT and should also work the same
for UNIX.




jre: not found!

A reader, October 26, 2004 - 2:14 pm UTC

Hi Tom,

I installed Oracle 9.2 on HP-UX. When I want to use 'oemapp console' I get this error:

oracle@dev2> oemapp console
/opt/oracle/product/9.0.1/bin/oemapp[113]: jre: not found.

I check the document and also set the:

SHLIB_PATH=$ORACLE_HOME/jdk/jre/lib/PA_RISC:
$ORACLE_HOME/jdk/jre/lib/PA_RISC/classic:
$ORACLE_HOME/rdbms/lib32:$ORACLE_HOME/lib32:
$ORACLE_HOME/mgw/lib32

But still get the same error!

Could you please tell me what is wrong?

Thanks,
-Arash



Tom Kyte
October 26, 2004 - 2:44 pm UTC

you installed 9.2?

why are you running out of 9.0.1 then?

Thanks. a very naive mistake!

A reader, October 26, 2004 - 2:54 pm UTC


Progress indicator V$SESSION_LONGOPS

Ronald, November 12, 2004 - 12:10 am UTC

There used to be a neat feature of OEM 8i that shows the progress of a running query step-by-step and percent-by-percent, just wondering if it is removed from the 9i OEM, cannot find it any more there.

Hi

A reader, April 11, 2005 - 2:34 pm UTC

Hi,

I am trying to configure email notification through OMS. My SMTP server requires authentication. When I try to send email through utl_smtp package I use base64 encoding and pass username and password using utl_smtp.command. Is there anything similar like this for OMS? How will I specify the username and password for my account using OMS? Please help.

Thanks.

Tom Kyte
April 11, 2005 - 2:38 pm UTC

please utilize support for installation/configuration -- I haven't done it myself.

connection

reader, April 11, 2005 - 8:23 pm UTC

(1) What is the type of connection from oem console to OMS? When I typed sysman/pwd and the OMS name on the "login to management server window", how does it establish connection to OMS server repository that is a 9i database?

(2) Then, what type of connection from OMS to agent process on the database server?

Thanks.

sysman in 9i OEM

Dave, May 26, 2005 - 1:35 pm UTC

(1) I also was wondering about the questions posted by the previous reader. Could you answer them?

(2) How sysman user is authenticated? Sysman is not the database user in 9i OEM? Where sysman user/pwd is stored to authenticate? Thanks.

Tom Kyte
May 26, 2005 - 2:36 pm UTC

check out support note: Note 220206.1

10g OMS

Mohamed Abd El Mawla, June 07, 2005 - 9:11 am UTC

Hi tom

I'm trying to install OMS for 10g database .

In 9i the Enterprise Manager configuration assistant (EMCA) can be used to configure the oms and the repository alos .

In 10g i can't find any documentation tht says do this no.1 and then no.2 .

When i tried to install the Oracle 10g grid control , i
recieved an error :

The specified management service on host server.domain.com and port 4889 is unreachable. Check the connection details for the management service to ensure tht u entered the value for the host name correctly .

What is the management service ?? Is it a component ??
I want to know the right way to install an Oracle Management server for an application uses (Database 10g and Application Server 10g) .

Thanks





Tom Kyte
June 07, 2005 - 9:36 am UTC

OEM - Compatibility

Richard, June 12, 2005 - 10:21 am UTC

Is there a matrix available that shows which modules/components of earlier releases of Oracle a particular version of OEM will work with?

Tom Kyte
June 12, 2005 - 11:11 am UTC

That would be a question for support.

Oracle 10g OMS

Mohamed Abd El Mawla, June 13, 2005 - 8:02 am UTC

Thanks Tom for your replying.

I discovered that i was trying to install the Oracle 10g Grid control agent only without oracle management service .

I'm asking now about the oracle tools that were available in 9i release :

Oracle Expert
Oracle DataGuard
Logminer Viewer
SQl Analyze
Tablespace Map
Index Spatial


Are these tools still available within the OMS 10g Grid Control or they have a separate software ??




Tom Kyte
June 13, 2005 - 11:37 am UTC

expert is sort of 'gone' - AWR, ADDM replace them.

the rest are all rolled into the dbconsole, the database console or grid control itself in one form or the other.

(don't know what "index spatial" is in the context of EM though)

oracle expert

reader, June 13, 2005 - 2:55 pm UTC

Is oracle expert a useful tool? I thought oracle expert gives recommendations based on some fixed set of rules.. As you frequently advises in this thread, one should tune based on wait events. Thanks.

Tom Kyte
June 13, 2005 - 8:53 pm UTC

one should find what to tune based on what is taking a long time and finding what you are waiting on.

(don't think I ever said "only tune waits". When tuning a tuned algorithm, see what it is waiting on)

If you have a query that takes 1,000 seconds and waits 0 seconds, I'd want to tune the query

change SID name during the installation

Dawar Naqvi, August 22, 2005 - 12:24 pm UTC

Tom,

I have installed Installing Oracle 10g R1 on SUSE SLES-9.

Priot to install Oracle my /etc/profile.d/oracle.sh file contains value for ORACLE_SID as ORACLE_SID=mydb.

During installation I have put different sid name as dtest.

I got configuration assistant (optional) error in the end.

I have fixed this by editing /etc/profile.d/oracle.sh and put the sid name "dtest".

ORACLE_SID=dtest

After that I am able to connect to Oracle through sqlplus environment.And starts listener.

But when I tried to startup database as below:

Enter user-name: sys as sysdba
Enter password:
Connected to an idle instance.

SQL> startup
ORA-01078: failure in processing system parameters
LRM-00109: could not open parameter file '/opt/oracle/product/10.1.0/db_1/dbs/initdtest.ora'

I also tried to run dbconsole and getting error as below:

oracle@dawar:~> emctl start dbconsole
TZ set to US/Pacific
OC4J Configuration issue. /opt/oracle/product/10.1.0/db_1/oc4j/j2ee/OC4J_DBConsole_abc.hsa.zz.org_dtest not found.

/opt/oracle/product/10.1.0/db_1/oc4j/j2ee> ls

deploy_db.ini  home  isqlplus  oc4j_applications  OC4J_DBConsole  OC4J_SEARCH

I am missing OC4J_DBConsole_abc.hsa.zz.org_dtest .

So I tried to run emctl to install again


emctl
TZ set to US/Pacific
EM Configuration issue. /opt/oracle/product/10.1.0/db_1/abc.hsa.zz.org_dtest not found.
How to fixed that?
Regards,
Dawar 

Tom Kyte
August 24, 2005 - 3:19 am UTC

please utilize support for installation configuration issues.

Configuring EM

Ashish Kapur, December 15, 2005 - 6:14 am UTC

Hi Tom,

I was configuring the emca of Oracle 10G on linux but it gave me an error, after checking the logs

Initialize core..

Performing CORE initialization

SP2-0265: verify must be set ON or OFF
No errors.
No errors.
No errors.
BEGIN
*
ERROR at line 1:
ORA-06502: PL/SQL: numeric or value error: character string buffer too small
ORA-06512: at line 269

Can you please let us know why the error is thrown out?

Tom Kyte
December 15, 2005 - 10:39 am UTC

please utilize support for installation/configuration issues.

oem

Donald, December 30, 2005 - 5:00 pm UTC

is it possbile to limit what the oem sees? I have users that need to select, insert, update and delete table data. However, I do not want them to read or view the packages or procedures at all. I have researched this in a number of areas, but no luck yet. any ideas?
thanks

Tom Kyte
December 31, 2005 - 10:53 am UTC

OEM would not be an appropriate tool to permit someone to just "select/insert/update/delete" some table data.

but Raptor would be:

</code> http://asktom.oracle.com/Misc/raptor-has-arrived.html <code>

Installing Agent

Dawar Naqvi, January 05, 2006 - 7:21 pm UTC

Hello Tom,

We have OEM running on Window.
Our Oracle database 10.1.0.4.0 is running on AIX 5.2.

I need to install Agent on AIX 5.2.
After that I can monitor AIX box from grid control.I have downloaded"AIX_Grid_Control_agent_download_10_1_0_4_1.cpio.gz" file.

Are there any good documentation on "how to install agent on unix box?".

OR give me summary or steps to accomplish my task.

thanks for any feed back.

Regards,
Dawar

Tom Kyte
January 06, 2006 - 1:08 pm UTC

please utilize support for installation/configuration...

A reader, January 06, 2006 - 5:00 pm UTC

Davar,

Check this link of Tim though its for Linux but might be of some help.

</code> http://www.oracle-base.com/articles/10g/Oracle10gR2GridControlInstallationOnRedHatAndCentOS.php <code>

managment server

kamal, January 20, 2006 - 5:47 pm UTC

hi tom
i have checked all the reviews and find them very useful for advance administartion. but i'm a naive user . i.m stuk up at a very basic point . my problem is i'm unable to log in managment server as i tyell u the scnario
i have a database aux1 and i created repository in that. in user kamal/kamal. my computer name is lexi. th e problem is when ever i try to login to oms after username n pwd it ask for managment server what shud be the value for this so that i'm able to login .. i tried many time but unable to do so ..please help so that i can learn something

A reader, February 02, 2006 - 4:39 am UTC


emctl start dbconsole

Vikas, February 04, 2006 - 8:16 am UTC

Hi Tom,

We recently installed Enterprise Manager on our database using DBCA with name of the host db-mercury.quark.com

However the box had its earlier name as db-erp.quark.com when we installed Oracle 10g.

Now when we try to start the emctl using the below command
it refers to the old box name and not the new name.

db-mercury.quark.com$ emctl status dbconsole
Oracle Enterprise Manager 10g Database Control Release 10.1.0.4
Copyright (c) 1996, 2004 Oracle Corporation. All rights reserved.
</code> http://db-erp.quark.com:5500/em/console/aboutApplication <code>
Oracle Enterprise Manager 10g is running.
-----------------------------------------------------------
Logs are generated in directory

/opt/app/oracle/product/10.1.0.4/db-erp.quark.com_erp/sysman/log

Since the machine is not pingable using the previous name we can't open the browser to use Enterprise manager to do administrative tasks.

Please let us know, what's the issue here. This would definitely help a lot of us.

Tom Kyte
February 06, 2006 - 12:12 am UTC

please utilize support for installation and configuration.

Enterprise Manager Repository Creation Assistant failed ??

raman, February 23, 2006 - 5:15 pm UTC

Hello Tom,

I have been trying to install Enterprise Manager Grid control ... when it reaches at 'Configuration Assistants' window, it does all but the last one, that is 'Enterprise Manager Repository Creation Assistant' which is getting failed and it is in recommended list.

===========================================================

Output generated from configuration assistant "Enterprise Manager Repository Creation Assistant" (attempt 4):
Unlocking the repository passwords
Parameter "orahome" = C:\oracle\OEMG
Parameter "command" = C:\oracle\OEMG/perl/5.6.1/bin/MSWin32-x86/perl.exe C:\oracle\OEMG/install/utl/changeSysmanPwd.pl
Parameter "syspwd" = *******
Parameter "sysmanpwd" = *******
Parameter "dbsnmppwd" = *******
Parameter "userlist" = sys,sysman,dbsnmp
Executing the command : C:\oracle\OEMG/perl/5.6.1/bin/MSWin32-x86/perl.exe C:\oracle\OEMG/install/utl/changeSysmanPwd.pl


SQL*Plus: Release 9.0.1.4.0 - Production on Thu Feb 23 15:38:18 2006

(c) Copyright 2001 Oracle Corporation. All rights reserved.

Connected.

User altered.


User altered.

Connected.

PL/SQL procedure successfully completed.

Disconnected from Oracle9i Enterprise Edition Release 9.0.1.5.1 - Production
With the Partitioning option
JServer Release 9.0.1.4.0 - Production

Changing password for sysman account succeeded.
Unlocking the repository password completed
Launching Repository Manager
Parameter "orahome" = C:\oracle\OEMG
Parameter "command" = C:\oracle\OEMG/sysman/admin/emdrep/bin/RepManager.bat -connect (DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=JJ0019W88154)(PORT=1521)))(CONNECT_DATA=(SERVICE_NAME=emrep.nash.tenn))) -out_of_box_setup -repos_user sysman -metalink_username _NOT_AVAILABLE_ -output_file C:\oracle\OEMG/sysman/log/RepManager.log
Parameter "syspwd" = *******
Parameter "sysmanpwd" = *******
Parameter "userpwd" = *******
Parameter "userlist" = sys,sysman,userpwd
Parameter "passenv" = true
Executing the command : C:\oracle\OEMG/sysman/admin/emdrep/bin/RepManager.bat -connect (DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=JJ0019W88154)(PORT=1521)))(CONNECT_DATA=(SERVICE_NAME=emrep.nash.tenn))) -out_of_box_setup -repos_user sysman -metalink_username _NOT_AVAILABLE_ -output_file C:\oracle\OEMG/sysman/log/RepManager.log

Enter SYS user's password :
Enter repository user password :
Enter MetaLink user password :
Getting temporary tablespace from database...
Found temporary tablespace: TEMP
Checking SYS Credentials ... Failed
SYS credentials or connect string is invalid.
Repository Creation Failed
Repository Creation Assistant Failed

Configuration assistant "Enterprise Manager Repository Creation Assistant" failed
===============================================

regards,

Tom Kyte
February 23, 2006 - 8:13 pm UTC

please utilize support for installation and configuration issues...

Tom Fox, February 23, 2006 - 8:21 pm UTC

Tom,

I noticed that the Oracle certified version matrix for OEM 10g says 8.1.7.4, 9.2.0.6 and higher, then 10.x.

I have some 9.2.0.1 and 9.2.0.4 instances, so does this mean that OEM 10g won't work with them?

--Tom

Tom Kyte
February 24, 2006 - 7:42 am UTC

doesn't mean it won't work - just that only production, supported releases are listed.

Here's the matrix

Tom Fox, February 23, 2006 - 8:23 pm UTC

Guess I should have include the matrix I was referring to:

Database* (single instance Enterprise Edition, Standard Edition, Personal Edition) and Listener

8.1.7.4,9.0.1.5, 9.2.0.6 and higher, 10.1.0.4 and higher, 10.2
(target support is only supported where platforms have a 10.x agent)

oracle management server error

Rohith, February 24, 2006 - 5:18 am UTC

I installed Oracle 8i (816) on NT server.
Using Enterprise Manager's Configuration Assistant I created repository.
and oracle management server also started

Now, When I logon to Enterprise Manager Console with the username and password (repository owner) and my machine name (Oracle1) for Management server, I get the error message,
********************************************
invalid login credentials supplied
********************************************

I checked Oracle is running on the machine. Please help me in resolving this.


restrict user to unlock account

Dawar Naqvi, March 08, 2006 - 2:54 pm UTC

Tom,

We are running third part application on our database server. (DB version is 10.1.0.4)
This application is running on (24*7) basis.

Due to any invalid attempts or other reasons
Some time user account has locked after work hours.

So we would like to give access or privileges to our help desk user
to unlock the user account.

We do not want to give any extra privilege to help desk user.

We want to restrict help desk user to unlock account.

Please note:
Help desk user do not have any client or tool install on their system.
Management also does not want to install client for them.

We could give them access of dbconsole. (OEM)

Can we restrict help desk user to unlock account?

Please give your feed back on it. Thanks

Regards,
Dawar

Tom Kyte
March 09, 2006 - 12:38 pm UTC

well, do they have a web browser?

create an application that takes inputs (the user to reset)
and that validates the user on the other end is allowed to reset that user (authenticate them)

and give that url to them.

restrict user to unlock account

Dawar Naqvi, March 09, 2006 - 3:22 pm UTC

Tom,

They do have browser.(Internet Explorer)

What tool should I use to create an application?
Your mean OracleBase,
Please clarify. thanks


Regards,
Dawar






Tom Kyte
March 09, 2006 - 4:00 pm UTC

any tool you guys use - I for example would be tempted to use htmldb (apex) to create it.

restrict user to unlock account

Dawar Naqvi, March 09, 2006 - 6:27 pm UTC

Tom,

We have no tool installed on our DB Server.

But I have an idea.
Need your comments.
Just assume this is Database Server 2.

Please read carefully, this is little complicated.

I have three servers in my first scenario:

One Database Server (1).
Oracle version 10.1.0.3.0
OS: Linux (SLES 8)

Application Server.
Both Infra & Middle tier (10. Rel 2) installed on the same box.
Full installation of business intelligence.
OS: Linux SLES 9

Window XP Box,
Forms & Reports Developer Suite: 9.0.4.1.0
It’s connected to Database server 1, 10.1.0.3.0.
I developed, maintained and upgrade forms & reports on this box and transfer to application server.
I also compiled on my Linux base Application server.

So I am running form/report based application on my application server.
and its work fine. We are using ulr to run this application from browser.

Second Scenario:

Now for my other group project inside same network.
I am running Oracle DB 10.1.0.4.0 on AIX box. (Database Server 2)

We are running third part application on this Database Server 2.
This application is running on (24*7) basis.

ACTION:

Now I want to create a FORM on my Windows Developer box.
That will allow help desk folk to unlock the account.
This Form should connect to Database Server 2 only

I will transfer this FORM to the Application server and compile it.

And give that URL to help desk user to run only this FORM based URL.

Please note:
This new FORM will only connect to the Database Server (2) from Win developer box and Application Server.
I just need to add entry in the tnsnames.ora files for this DB server 2.

Do I miss any thing in my plan?

Please give your suggestion or approval.
I need your feed backs.

Thanks
Dawar


Tom Kyte
March 10, 2006 - 11:57 am UTC

... We have no tool installed on our DB Server. ...


don't need one, I would assume SOMEWHERE you have an application server and SOMEWHERE you write programs that use this database?

How to give limited privileges to the user to .....

Dawar Naqvi, March 12, 2006 - 5:25 pm UTC

Tom,

Related to above.
But do not have to read above.

I have created a FORM based on all_users table.

It is a very simple FORM.
This FORM allows user to unlock the account.
I have created a procedure in my database to unlock the account.
Now I called this procedure in the when button pressed trigger.

unlock_account(:item);

Currently this functionality is working if I am login as a privelege user.
In my case one of our main schema ABC.

My plan to put this FORM into our appserver and give this url to helpdesk user to unlock account.

For this purpose I need to create account for help desk user.

Which should have only required priviliges.

How to give limited privileges to the user to the help desk to perform this functionality only?

Here is the procedure in the database to unlock account:

create or replace procedure unlock_account (p_username in all_users.username%type)isbegin execute immediate 'alter user ' || p_username || ' account unlock';end;

when-button-pressed trigger at form level, I have a code as below



Regards,
Dawar

Tom Kyte
March 13, 2006 - 12:05 am UTC

grant execute on unlock_acount to that_user;

However, before doing that - you best bullet proof your routine. It is subject to a huge amount of SQL Injection.

Let me pass a username = SCOTT default tablespace system

Or Let me pass a username = SCOTT identified by foobar


Your routine would let any help desk analyst change anything about a user pretty much.


You need to verify your inputs are "safe" before rolling this out.

continue from above

Dawar, March 14, 2006 - 12:32 pm UTC

Tom,


FORM was working fine from APP server and the from the builder too.

Now suddenly I am not able to unlock account.

and getting this message


FRM-40735:WHEn-BUTTON-PRESED trigger unhandled exception ORA-00940


I tried to modify my procedure earlier
but bring it back to the previous code as above.

Any thought.

Dawar

Tom Kyte
March 15, 2006 - 9:08 am UTC

invalid alter command, my thoughts:

you have a bug in your procedure, it is building an invalid alter command.

continue from above

dawar, March 14, 2006 - 5:11 pm UTC

Tom,

I have created new procedure and its work.

I do not understand it.
I wrote the procedure earlier and its work with my FORM.

After I giot error above.

I little modified my procedure and its work.
Could you please see the above two note from me.

And give your feed back.

Please note: We have more than two people can access our DB.

Is it possible some one make any change?

I was not even able to my old procdure from sqlplus.
yesrtay was fine.

Regards,
Dawar

sysman

jas, March 17, 2006 - 4:07 pm UTC

I am dropping sysman tablespace sysaux is being fredd but undotablespace is biemg used.
while dropping a user whu undotablespace has to be used ?.



Tom Kyte
March 17, 2006 - 6:03 pm UTC

because we generate UNDO in the event that halfway through the drop user we have to undo what we just did.

DDL runs SQL, SQL is SQL, SQL is protected by redo and undo.

Oracle9i - Intelligent Agent on Fedora Core 4 Linux

Vikas Sangar, March 27, 2006 - 1:10 am UTC

Dear Mr. Kyte,

Realizing the advantages rendered by Oracle Managment Server, I thought of utilizing its benefits for our Oracle9i Database Server, on Fedora Core 4 Linux (FC4) Platform. But whenever I try to Find/Search/Add for the node (Our 9iR2 Database on FC4 Linux, using WindowsXP Platform (client Machine) where I have installed the OMS), The OMS fails to automatically detect our FC4 Database Server, and I am flashed with the message which likely means "The OMS could not communicate with the Agent, you need Agent for automatically detecting the nodes". however the "Manual" addition of the same machine/node succeeds.

When, I try to start the Agent on my FC4 Linux Oracle9i Database Machine. I am getting following messages :-

[oracle@FC4Lnx /]$ agentctl start

DBSNMP for Linux: Version 9.2.0.4.0 - Production on 27-MAR-2006 10:43:41

Copyright (c) 2003 Oracle Corporation. All rights reserved.

Starting Oracle Intelligent Agent.../opt/oracle/920/bin/dbsnmpwd : line 156: 26287 Segmentation fault nohup $ORACLE_HOME/bin /dbsnmp $* >>$DBSNMP_WDLOGFILE 2>&1
/opt/oracle/920/bin/dbsnmpwd: line 156: 26300 Segmentation fault nohup $ORACLE_HOME/bin/dbsnmp $* >>$DBSNMP_WDLOGFILE 2>&1
/opt/oracle/920/bin/dbsnmpwd: line 156: 26312 Segmentation fault nohup $ORACLE_HOME/bin/dbsnmp $* >>$DBSNMP_WDLOGFILE 2>&1
/opt/oracle/920/bin/dbsnmpwd: line 156: 26324 Segmentation fault nohup $ORACLE_HOME/bin/dbsnmp $* >>$DBSNMP_WDLOGFILE 2>&1


[oracle@FC4Lnx /]$ agentctl status

DBSNMP for Linux: Version 9.2.0.4.0 - Production on 27-MAR-2006 10:44:05

Copyright (c) 2003 Oracle Corporation. All rights reserved.

Could not contact agent. It may not be running.

Can you please suggest me how to resolve this issue and help me getting a way out of this Problem? Also, being a bit more inquisitive, I would also like to put before you, few more questions related to above:-

-->What is "Segmentation fault"?

-->How can I Start/Enable my Oracle9i Intelligent Agent on my FC4 Database server and avail the full benefits fom the OMS?

-->How can I install/configure OMS directly on my FC4 Linux Database Server? (if you could provide any valid link to any site/white paper/documntation for achieving the same)

-->And finally, What factors might be causing this Agent related problem?

I will be highly grateful for your valuable help and direction in this regards.
Take care, Regards..
Vikas.

Tom Kyte
March 27, 2006 - 9:47 am UTC

please utilize support for an issue like this (configuration/installation)

Oracle9i - Intelligent Agent on Fedora Core 4 Linux

Vikas Sangar, March 27, 2006 - 11:42 pm UTC

Dear Mr. Kyte,

Yes, support would be a right/great place to resolve this issue.

But, unfortunately I dont have access to Oracle Support, so I thought you might help me out with this problem.

May be, if you could provide me any useful link for the same?

Take care, regards..
Vikas.

Installation client oracle 8.1.6

Penazzi, June 06, 2006 - 8:26 am UTC

I try to install the client oracle version 8.1.6, but when I click in the executable file (setup.exe), nothing happens. I tried to install the client in many computers too, but nothing happened.
My operation system is Windows XP with service pack 2 and CA software (etrust antivirus).

Tom Kyte
June 06, 2006 - 8:55 am UTC

sounds like the infamous p4 Java JRE problem.

Hard to remember so so so so very very very far back in time.


</code> http://asktom.oracle.com/pls/asktom/f?p=100:11:::::P11_QUESTION_ID:5560566475204#13837137575576 <code>

I'm totally guessing - since 816 is so far out of support...

reader

A reader, July 14, 2006 - 1:51 pm UTC

I saw a radio button on OEM (9.2 version) on
database => storage => tablespaces => tablespace name
=> storage (tab)

o minimum size

How to find this vale from the command line database views

This parameter is not minextents. Regardless of the initial and next value of extents, it creates one (1) extent of his size (minimum size) for objects created in the tablesspace .

Ex:
initial 1m
next 1m
minimum size 100m

Tables created is allocated one (1) extent of 100 MB




Tom Kyte
July 14, 2006 - 2:45 pm UTC

don't know what that "button" might be about.

Use locally managed tablespaces - forget about initial/next...

reader

A reader, July 14, 2006 - 2:23 pm UTC

Never mind. Probably it is minextents

discover nodes automaticly using OEM

Li, September 26, 2006 - 7:25 am UTC

Hi,

I've installed OEM (9i) on a Windows 2000 professional machine. When I try to discover automaticly nodes, I can juste see the tow databases located on the local machine. when I attempt to discover database in another machine, by spécifying the ip adress of that machine, it fails. Note that, the agent is started on the remote machine, I can ping this remote machine, but, I can't discover it automaticly. So I can't do no backup, no job, no event and nothing interesting at all :( !

I've to say that OEM is installed on a virtual machine, but I don't think that may cause any troubles.

Thanks for your help,

Gathering Statistics

A reader, October 23, 2006 - 5:31 am UTC

Hi Tom,

do you recommend gather statistics using dbms_stats for the oem repository?

Thanks

Tom Kyte
October 23, 2006 - 10:13 am UTC

ask support what they recommend and what is supported.

Adding target to an enterprise manager

A reader, September 12, 2011 - 2:55 pm UTC

Dear Tom,

In a discussion I have been asked: "How can I add new target to an existing OEM set up?"
Can you please let me know what Target means? Does it mean adding separate Target database in a single OEM?
Also let me know how I can do it? Thanks,

Oracle Enterprise Manager reference information

Steve, August 24, 2021 - 3:27 pm UTC

Chris Saxon
August 24, 2021 - 4:01 pm UTC

Thanks for sharing